diff mbox series

[bug#42338,32/34] gnu: Add php-phpunit-php-invoker.

Message ID 20200712222538.18092-32-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpunit-php-invoker): New variable.
---
 gnu/packages/php-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 1b6669abcc..484fb17790 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -745,3 +745,26 @@  processing, and rendering functionality for PHP code coverage information.")
 of PHPUnit.  It provides a utility class for timing.")
     (home-page "https://github.com/sebastianbergmann/php-timer/")
     (license license:bsd-3)))
+
+(define-public php-phpunit-php-invoker
+  (package
+    (name "php-phpunit-php-invoker")
+    (version "3.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sebastianbergmann/php-invoker.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1xs7m0wiminnhkd400glmixyhrx1ir710j6fds9i03dhicfcj7db"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (synopsis "PHP library for invoking functions")
+    (description "This package contains a library to invoke callables with a
+timeout.")
+    (home-page "https://github.com/sebastianbergmann/php-invoker/")
+    (license license:bsd-3)))