diff mbox series

[bug#42338,14/34] gnu: Add php-phpdocumentor-reflection-docblock.

Message ID 20200712222538.18092-14-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpdocumentor-reflection-docblock): New
variable.
---
 gnu/packages/php-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 93d8649bee..df9c490bbf 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -304,3 +304,31 @@  to analyze the code structure.")
 types and structural element names.")
     (home-page "http://www.phpdoc.org")
     (license license:expat)))
+
+(define-public php-phpdocumentor-reflection-docblock
+  (package
+    (name "php-phpdocumentor-reflection-docblock")
+    (version "5.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/phpDocumentor/ReflectionDocBlock.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1bsqwcq5ix7f5p56kc92pl1nqpjdpfc92pjvwyshp1syrrspa3rr"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (inputs
+     `(("php-webmozart-assert" ,php-webmozart-assert)
+       ("php-phpdocumentor-reflection-common" ,php-phpdocumentor-reflection-common)
+       ("php-phpdocumentor-type-resolver" ,php-phpdocumentor-type-resolver)))
+    (synopsis "Library for retrieving documentation in code fro the code")
+    (description "With this component, a library can provide support for
+annotations via DocBlocks or otherwise retrieve information that is embedded
+in a DocBlock.")
+    (home-page "https://github.com/phpDocumentor/ReflectionDocBlock")
+    (license license:expat)))