diff mbox series

[bug#42338,31/34] gnu: Add php-phpunit-php-timer.

Message ID 20200712222538.18092-31-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpunit-php-timer): New variable.
---
 gnu/packages/php-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 2d186c5190..1b6669abcc 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -722,3 +722,26 @@  the types of the PHP type system.")
 processing, and rendering functionality for PHP code coverage information.")
     (home-page "https://github.com/sebastianbergmann/php-code-coverage")
     (license license:bsd-3)))
+
+(define-public php-phpunit-php-timer
+  (package
+    (name "php-phpunit-php-timer")
+    (version "5.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sebastianbergmann/php-timer.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0hyy5c8b22zki6836a7fhzr3s6dpvga33r2rzfrsbv1arh19ay60"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (synopsis "Utility class for timing")
+    (description "This package contains a stand-alone component originally part
+of PHPUnit.  It provides a utility class for timing.")
+    (home-page "https://github.com/sebastianbergmann/php-timer/")
+    (license license:bsd-3)))