diff mbox series

[bug#42338,30/34] gnu: Add php-phpunit-php-code-coverage.

Message ID 20200712222538.18092-30-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpunit-php-code-coverage): New
variable.
---
 gnu/packages/php-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 9a50c431b7..2d186c5190 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -690,3 +690,35 @@  operate on resources.")
 the types of the PHP type system.")
     (home-page "https://github.com/sebastianbergmann/type")
     (license license:bsd-3)))
+
+(define-public php-phpunit-php-code-coverage
+  (package
+    (name "php-phpunit-php-code-coverage")
+    (version "8.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sebastianbergmann/php-code-coverage.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1qr7x9y8636bvv0fk8hl0kl9d2y8fy6qw65kpi4yb1yyqhfddkgh"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (inputs
+     `(("php-theseer-tokenizer" ,php-theseer-tokenizer)
+       ("php-sebastian-version" ,php-sebastian-version)
+       ("php-sebastian-environment" ,php-sebastian-environment)
+       ("php-sebastian-code-unit-reverse-lookup"
+	,php-sebastian-code-unit-reverse-lookup)
+       ("php-phpunit-php-text-template" ,php-phpunit-php-text-template)
+       ("php-phpunit-php-token-stream" ,php-phpunit-php-token-stream)
+       ("php-phpunit-php-file-iterator" ,php-phpunit-php-file-iterator)))
+    (synopsis "Code coverage information library")
+    (description "This package is a library that provides collection,
+processing, and rendering functionality for PHP code coverage information.")
+    (home-page "https://github.com/sebastianbergmann/php-code-coverage")
+    (license license:bsd-3)))