diff mbox series

[bug#42338,26/34] gnu: Add php-sebastian-global-state.

Message ID 20200712222538.18092-26-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-global-state): New variable.
---
 gnu/packages/php-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 899f6a3f69..4872523b31 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -591,3 +591,30 @@  for equality.")
 inherited and non-public ones.")
     (home-page "https://github.com/sebastianbergmann/object-reflector/")
     (license license:bsd-3)))
+
+(define-public php-sebastian-global-state
+  (package
+    (name "php-sebastian-global-state")
+    (version "4.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sebastianbergmann/global-state.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0x6sfw353px5y7azipn2mb15w7w7zxbbpbv3dbhhkryrhad8w064"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (inputs
+     `(("php-sebastian-recursion-context" ,php-sebastian-recursion-context)
+       ("php-sebastian-object-reflector" ,php-sebastian-object-reflector)))
+    (synopsis "Snapshotting of global state")
+    (description "This package contains a stand-alone component originally part
+of PHPUnit.  It provides support for creating a snapshot of the global state
+of a PHP program.")
+    (home-page "http://www.github.com/sebastianbergmann/global-state")
+    (license license:bsd-3)))