diff mbox series

[bug#42338,23/34] gnu: Add php-sebastian-environment.

Message ID 20200712222538.18092-23-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-environment): New variable.
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index aff2ed79a7..9ee823bcda 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -517,3 +517,25 @@  that filters files based on a list of suffixes.")
 for equality.")
     (home-page "https://github.com/sebastianbergmann/comparator")
     (license license:bsd-3)))
+
+(define-public php-sebastian-environment
+  (package
+    (name "php-sebastian-environment")
+    (version "5.1.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sebastianbergmann/environment.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0lhaiwk6dbwii9kmjaq3gjl2x5s1rikmxkvmy4mjvjcbi7imp38s"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (synopsis "Handle HHVM and PHP environments")
+    (description "This package provides functionality to handle HHVM/PHP environments")
+    (home-page "http://www.github.com/sebastianbergmann/environment")
+    (license license:bsd-3)))