diff mbox series

[bug#42338,07/34] gnu: Add php-myclabs-deep-copy.

Message ID 20200712222538.18092-7-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-myclabs-deep-copy): New variable.
---
 gnu/packages/php-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index ae7d7ff6b2..a45726a484 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -130,3 +130,28 @@  PHP variables")
 variables for visualization")
     (home-page "http://www.github.com/sebastianbergmann/exporter")
     (license license:bsd-3)))
+
+(define-public php-myclabs-deep-copy
+  (package
+    (name "php-myclabs-deep-copy")
+    (version "1.10.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/myclabs/DeepCopy.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1ms4qhx5cf19ggdicnd7qjrigwam206py6mj6nw8bz71mafq9nbi"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (synopsis "Create copies of PHP objects")
+    (description "This package contains a facility to create deep copies (clones)
+of PHP objects.  This package not only creates a new copy of an object, it
+recursively create new copies of any object referenced by the object.  It is
+designed to work even in the presence of cycles in the association graph.")
+    (home-page "https://github.com/myclabs/DeepCopy.git")
+    (license license:expat)))