diff mbox series

[bug#42338,16/34] gnu: Add php-sebastian-code-unit-reverse-lookup.

Message ID 20200712222538.18092-16-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-code-unit-reverse-lookup): New
variable.
---
 gnu/packages/php-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index f54b875d92..13584273f9 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -355,3 +355,26 @@  in a DocBlock.")
 PHP source code into XML and potentially other formats.")
     (home-page "https://github.com/theseer/tokenizer")
     (license license:bsd-3)))
+
+(define-public php-sebastian-code-unit-reverse-lookup
+  (package
+    (name "php-sebastian-code-unit-reverse-lookup")
+    (version "2.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sebastianbergmann/code-unit-reverse-lookup.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0lppni3qcd6gx50jf16y3n71ldj12xjd06kl9ml78zd5p2s6z4qc"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (synopsis "Look up function name from location")
+    (description "This package provides a facility to look up which function or
+method a line of code belongs to.")
+    (home-page "https://github.com/sebastianbergmann/code-unit-reverse-lookup/")
+    (license license:bsd-3)))