diff mbox series

[bug#42338,15/34] gnu: Add php-theseer-tokenizer.

Message ID 20200712222538.18092-15-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-theseer-tokenizer): New variable.
---
 gnu/packages/php-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index df9c490bbf..f54b875d92 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -332,3 +332,26 @@  annotations via DocBlocks or otherwise retrieve information that is embedded
 in a DocBlock.")
     (home-page "https://github.com/phpDocumentor/ReflectionDocBlock")
     (license license:expat)))
+
+(define-public php-theseer-tokenizer
+  (package
+    (name "php-theseer-tokenizer")
+    (version "1.1.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/theseer/tokenizer.git")
+                     (commit "11336f6f84e16a720dae9d8e6ed5019efa85a0f9")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0j436a3jpynnlqrvd7la7a7smj78aklkragwa9l8p91973xra18l"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (synopsis "Convert PHP to XML")
+    (description "This package provides a small library for converting tokenized
+PHP source code into XML and potentially other formats.")
+    (home-page "https://github.com/theseer/tokenizer")
+    (license license:bsd-3)))