diff mbox series

[bug#42338,13/34] gnu: Add php-phpdocumentor-type-resolver.

Message ID 20200712222538.18092-13-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpdocumentor-type-resolver): New
variable.
---
 gnu/packages/php-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 9b604c46f0..93d8649bee 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -279,3 +279,28 @@  the code structure")
 to analyze the code structure.")
     (home-page "http://www.phpdoc.org")
     (license license:expat)))
+
+(define-public php-phpdocumentor-type-resolver
+  (package
+    (name "php-phpdocumentor-type-resolver")
+    (version "1.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/phpDocumentor/TypeResolver.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0wshv49z4hxraygg2vhzn0s9ih2y9ymzpcnyjfk14vcfq5yx53l9"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (inputs
+     `(("php-phpdocumentor-reflection-common" ,php-phpdocumentor-reflection-common)))
+    (synopsis "Resolver of class names, types and structural element names")
+    (description "This package provides a PSR-5 based resolver of class names,
+types and structural element names.")
+    (home-page "http://www.phpdoc.org")
+    (license license:expat)))