diff mbox series

[bug#42338,20/34] gnu: Add php-phpunit-php-text-template.

Message ID 20200712222538.18092-20-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpunit-php-text-template): New
variable.
---
 gnu/packages/php-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 5d06bea0cb..b5abcaae36 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -447,3 +447,25 @@  number of Git-hosted PHP projects.")
 that filters files based on a list of suffixes.")
     (home-page "https://github.com/sebastianbergmann/php-file-iterator/")
     (license license:bsd-3)))
+
+(define-public php-phpunit-php-text-template
+  (package
+    (name "php-phpunit-php-text-template")
+    (version "2.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sebastianbergmann/php-text-template.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0x38kj1xlnysg9xgad560k361l93vh32mvkyfn7rss3p2r319jhx"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (synopsis "Simple template engine")
+    (description "This package contains a library for a simple templating engine.")
+    (home-page "https://github.com/sebastianbergmann/php-text-template/")
+    (license license:bsd-3)))