diff mbox series

[bug#42338,06/34] gnu: Add php-sebastian-exporter.

Message ID 20200712222538.18092-6-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-exporter): New variable.
---
 gnu/packages/php-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index b04b8e0859..ae7d7ff6b2 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -105,3 +105,28 @@  instantiate objects in PHP without invoking their constructors")
 PHP variables")
     (home-page "http://www.github.com/sebastianbergmann/recursion-context")
     (license license:bsd-3)))
+
+(define-public php-sebastian-exporter
+  (package
+    (name "php-sebastian-exporter")
+    (version "4.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sebastianbergmann/exporter.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "03xj9gbi8ifnbj5n72gfpwyg65l71gg1r8yvzpbg6d3yxbqaa8f6"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (inputs
+     `(("php-sebastian-recursion-context" ,php-sebastian-recursion-context)))
+    (synopsis "Visualize PHP variables")
+    (description "This package provides the functionality to export PHP
+variables for visualization")
+    (home-page "http://www.github.com/sebastianbergmann/exporter")
+    (license license:bsd-3)))