diff mbox series

[bug#42338,10/34] gnu: Add php-symfony-polyfill-ctype.

Message ID 20200712222538.18092-10-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php.scm (php-symfony-polyfill-ctype): New variable.
---
 gnu/packages/php-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index f0f4fe650a..51e51ac51b 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -207,3 +207,26 @@  and constraints.")
 information from a PHP Archive (PHAR)")
     (home-page "https://phar.io")
     (license license:bsd-3)))
+
+(define-public php-symfony-polyfill-ctype
+  (package
+    (name "php-symfony-polyfill-ctype")
+    (version "1.17.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/symfony/polyfill-ctype.git")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0bh22vwq2idy7fi8ajm6aggjdvds64s98y9854b5gl9s84dk9pz8"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (synopsis "Ctype functions for older PHP versions")
+    (description "This component provides @code{ctype_*} functions to users
+who run php versions without the ctype extension.")
+    (home-page "https://symfony.com")
+    (license license:expat)))