diff mbox series

[bug#42338,17/34] gnu: Add php-phpunit-php-token-stream.

Message ID 20200712222538.18092-17-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpunit-php-token-stream): New variable.
---
 gnu/packages/php-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 13584273f9..344c413d2c 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -378,3 +378,26 @@  PHP source code into XML and potentially other formats.")
 method a line of code belongs to.")
     (home-page "https://github.com/sebastianbergmann/code-unit-reverse-lookup/")
     (license license:bsd-3)))
+
+(define-public php-phpunit-php-token-stream
+  (package
+    (name "php-phpunit-php-token-stream")
+    (version "4.0.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sebastianbergmann/php-token-stream.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0iv8ssvyjhgxa1qpp5s8i0j409w49s2kc9qwv1c27qgdhv7yhf7h"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (synopsis "Wrapper around PHP's tokenizer extension")
+    (description "This library provides a wrapper around PHP's tokenizer
+extension.")
+    (home-page "https://github.com/sebastianbergmann/php-token-stream/")
+    (license license:bsd-3)))