diff mbox series

[bug#42338,11/34] gnu: Add php-webmozart-assert.

Message ID 20200712222538.18092-11-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-webmozart-assert): New variable.
---
 gnu/packages/php-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 51e51ac51b..ffc2eb7b11 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -230,3 +230,28 @@  information from a PHP Archive (PHAR)")
 who run php versions without the ctype extension.")
     (home-page "https://symfony.com")
     (license license:expat)))
+
+(define-public php-webmozart-assert
+  (package
+    (name "php-webmozart-assert")
+    (version "1.9.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/webmozart/assert.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1q9bp4sp11r8ghdzr0qswdf1k5bf9b5s525im3kspar6y8019sh9"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (inputs
+     `(("php-symfony-polyfill-ctype" ,php-symfony-polyfill-ctype)))
+    (synopsis "Assertions to validate method input/output with nice error messages.")
+    (description "This library contains efficient assertions to test the input
+and output of PHP methods.")
+    (home-page "https://github.com/webmozart/assert")
+    (license license:expat)))