diff mbox series

[bug#42338,05/34] gnu: Add php-sebastian-recursion-context.

Message ID 20200712222538.18092-5-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-recursion-context): New variable.
---
 gnu/packages/php-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 28d8909dad..b04b8e0859 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -82,3 +82,26 @@  to build its own store-aware autoloading feature.")
 instantiate objects in PHP without invoking their constructors")
     (home-page "https://www.doctrine-project.org/projects/instantiator.html")
     (license license:expat)))
+
+(define-public php-sebastian-recursion-context
+  (package
+    (name "php-sebastian-recursion-context")
+    (version "4.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sebastianbergmann/recursion-context.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0glpydmvr95f9xbmh76vgid2nz7rf6lxwfz1j7ksvgmf4m1dniyz"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (synopsis "Process PHP variables recursively")
+    (description "This package provides functionality to recursively process
+PHP variables")
+    (home-page "http://www.github.com/sebastianbergmann/recursion-context")
+    (license license:bsd-3)))