diff mbox series

[bug#42338,24/34] gnu: Add php-phpspec-prophecy.

Message ID 20200712222538.18092-24-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-phpspec-prophecy): New variable.
---
 gnu/packages/php-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 9ee823bcda..8c96d9aabc 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -539,3 +539,32 @@  for equality.")
     (description "This package provides functionality to handle HHVM/PHP environments")
     (home-page "http://www.github.com/sebastianbergmann/environment")
     (license license:bsd-3)))
+
+(define-public php-phpspec-prophecy
+  (package
+    (name "php-phpspec-prophecy")
+    (version "1.11.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/phpspec/prophecy.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1pd6iz6pbfpaz5rqa36q01l569zgiqpjgqmzw3rra2qdh1jrwdy1"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (inputs
+     `(("php-sebastian-recursion-context" ,php-sebastian-recursion-context)
+       ("php-doctrine-instantiator" ,php-doctrine-instantiator)
+       ("php-sebastian-comparator" ,php-sebastian-comparator)
+       ("php-phpdocumentor-reflection-docblock"
+	,php-phpdocumentor-reflection-docblock)))
+    (synopsis "Mocking framework for PHP 5.3+")
+    (description "This package contains a mocking framework for testing PHP
+5.3+ projects.")
+    (home-page "https://github.com/phpspec/prophecy")
+    (license license:expat)))