diff mbox series

[bug#66603,02/29] gnu: Add go-github-com-lestrrat-go-strftime.

Message ID 20231018093836.2056-2-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-lestrrat-go-strftime): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cd5704929f..1e2192eb80 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1716,6 +1716,31 @@  (define-public go-github-com-lestrrat-go-envload
     (description "Restore environment variables, so you can break em")
     (license license:expat)))
 
+(define-public go-github-com-lestrrat-go-strftime
+  (package
+    (name "go-github-com-lestrrat-go-strftime")
+    (version "1.0.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/lestrrat-go/strftime")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1iqzxmj3ijldjf99acy44qrrzvfxzn0vza3m0c9bw46bg8v1wsyc"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/lestrrat-go/strftime"
+       #:tests? #f))
+    (propagated-inputs `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+                         ("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
+                         ("go-github-com-lestrrat-go-envload" ,go-github-com-lestrrat-go-envload)))
+    (home-page "https://github.com/lestrrat-go/strftime")
+    (synopsis "strftime")
+    (description "Fast strftime for Go")
+    (license license:expat)))
+
 (define-public go-github-com-leonelquinteros-gotext
   (package
     (name "go-github-com-leonelquinteros-gotext")