diff mbox series

[bug#66603,17/29] gnu: Add go-github-com-mailru-easyjson.

Message ID 20231018093836.2056-17-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-mailru-easyjson): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c6287c979f..ffe803be5e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2090,6 +2090,29 @@  (define-public go-github-com-josharian-intern
 strings may be removed automatically at any time without notification.  All
 functions may be called concurrently with themselves and each other.")
     (license license:expat)))
+
+(define-public go-github-com-mailru-easyjson
+  (package
+    (name "go-github-com-mailru-easyjson")
+    (version "0.7.7")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mailru/easyjson")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0clifkvvy8f45rv3cdyv58dglzagyvfcqb63wl6rij30c5j2pzc1"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/mailru/easyjson"))
+    (propagated-inputs `(("go-github-com-josharian-intern" ,go-github-com-josharian-intern)))
+    (home-page "https://github.com/mailru/easyjson")
+    (synopsis "easyjson")
+    (description
+     "Package easyjson contains marshaler/unmarshaler interfaces and helper functions.")
+    (license license:expat)))
 (define-public go-github-com-pkg-xattr
   (package
     (name "go-github-com-pkg-xattr")