diff mbox series

[bug#66603,21/29] gnu: Add go-golang-org-x-text.

Message ID 20231018093836.2056-21-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-golang-org-x-text): New variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0a213c71b4..91839a53ec 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2197,6 +2197,34 @@  (define-public go-github-com-pkg-profile
      "Package profile provides a simple way to manage runtime/pprof profiling of your
 Go application.")
     (license license:bsd-2)))
+
+(define-public go-golang-org-x-text
+  (package
+    (name "go-golang-org-x-text")
+    (version "0.13.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://go.googlesource.com/text")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "15k0hrivb22qwifiimqaz36xcyr86ml4h27s4jlczmybqly7hlwg"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "golang.org/x/text"))
+    (propagated-inputs `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
+                         ("go-golang-org-x-mod" ,go-golang-org-x-mod)
+                         ("go-golang-org-x-tools" ,go-golang-org-x-tools)))
+    (home-page "https://golang.org/x/text")
+    (synopsis "Go Text")
+    (description
+     "text is a repository of text-related packages related to internationalization
+(i18n) and localization (l10n), such as character encodings, text
+transformations, and locale-specific text handling.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-pkg-xattr
   (package
     (name "go-github-com-pkg-xattr")