diff mbox series

[bug#66603,04/29] gnu: Add go-github-com-orisano-pixelmatch.

Message ID 20231018093836.2056-4-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-orisano-pixelmatch): New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index acc5d3163b..d0caed8d41 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1797,6 +1797,28 @@  (define-public go-github-com-ledongthuc-pdf
     (synopsis "PDF Reader")
     (description "Package pdf implements reading of PDF files.")
     (license license:bsd-3)))
+
+(define-public go-github-com-orisano-pixelmatch
+  (package
+    (name "go-github-com-orisano-pixelmatch")
+    (version "0.0.0-20230914042517-fa304d1dc785")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/orisano/pixelmatch")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1lplxfif5mfqnd0jjph2vd25c3bpr3idfs2axh8z0ib0zdkwca32"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/orisano/pixelmatch"))
+    (home-page "https://github.com/orisano/pixelmatch")
+    (synopsis "pixelmatch")
+    (description
+     "@@url{https://github.com/mapbox/pixelmatch,mapbox/pixelmatch} ports for go.")
+    (license license:expat)))
 (define-public go-github-com-pkg-xattr
   (package
     (name "go-github-com-pkg-xattr")