diff mbox series

[bug#66603,10/29] gnu: Add go-github-com-ianlancetaylor-demangle.

Message ID 20231018093836.2056-10-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-ianlancetaylor-demangle): New variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f80eb33cb6..2267c2db27 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1920,6 +1920,33 @@  (define-public go-github-com-chzyer-readline
     (description
      "Readline is a pure go implementation for GNU-Readline kind library.")
     (license license:expat)))
+
+(define-public go-github-com-ianlancetaylor-demangle
+  (package
+    (name "go-github-com-ianlancetaylor-demangle")
+    (version "0.0.0-20230524184225-eabc099b10ab")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ianlancetaylor/demangle")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1pvlg1adp50hnw8dz7il473xb197ixirg26cy5hj3ngb4qlajwvc"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/ianlancetaylor/demangle"))
+    (home-page "https://github.com/ianlancetaylor/demangle")
+    (synopsis "github.com/ianlancetaylor/demangle")
+    (description
+     "Package demangle defines functions that demangle GCC/LLVM C++ and Rust symbol
+names.  This package recognizes names that were mangled according to the C++ ABI
+defined at
+@@url{http://codesourcery.com/cxx-abi/,http://codesourcery.com/cxx-abi/} and the
+Rust ABI defined at
+@@url{https://rust-lang.github.io/rfcs/2603-rust-symbol-name-mangling-v0.html,https://rust-lang.github.io/rfcs/2603-rust-symbol-name-mangling-v0.html}")
+    (license license:bsd-3)))
 (define-public go-github-com-pkg-xattr
   (package
     (name "go-github-com-pkg-xattr")