diff mbox series

[bug#66603,18/29] gnu: Add go-github-com-google-pprof.

Message ID 20231018093836.2056-18-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-google-pprof): New variable.
---
 gnu/packages/golang.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ffe803be5e..2fe4443ce0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2113,6 +2113,40 @@  (define-public go-github-com-mailru-easyjson
     (description
      "Package easyjson contains marshaler/unmarshaler interfaces and helper functions.")
     (license license:expat)))
+
+(define-public go-github-com-google-pprof
+  (package
+    (name "go-github-com-google-pprof")
+    (version "0.0.0-20230926050212-f7f687d19a98")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/google/pprof")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1hmypb2zxixy2wfzddss68nr2c98bk30mqym7khd584iyqbx0adn"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/google/pprof"))
+    (propagated-inputs `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
+                         ("go-github-com-mailru-easyjson" ,go-github-com-mailru-easyjson)
+                         ("go-github-com-josharian-intern" ,go-github-com-josharian-intern)
+                         ("go-github-com-gobwas-ws" ,go-github-com-gobwas-ws)
+                         ("go-github-com-gobwas-pool" ,go-github-com-gobwas-pool)
+                         ("go-github-com-gobwas-httphead" ,go-github-com-gobwas-httphead)
+                         ("go-github-com-chromedp-sysutil" ,go-github-com-chromedp-sysutil)
+                         ("go-github-com-chromedp-cdproto" ,go-github-com-chromedp-cdproto)
+                         ("go-github-com-ianlancetaylor-demangle" ,go-github-com-ianlancetaylor-demangle)
+                         ("go-github-com-chzyer-readline" ,go-github-com-chzyer-readline)
+                         ("go-github-com-chromedp-chromedp" ,go-github-com-chromedp-chromedp)))
+    (home-page "https://github.com/google/pprof")
+    (synopsis "Introduction")
+    (description
+     "pprof is a tool for collection, manipulation and visualization of performance
+profiles.")
+    (license license:asl2.0)))
 (define-public go-github-com-pkg-xattr
   (package
     (name "go-github-com-pkg-xattr")