diff mbox series

[bug#66603,20/29] gnu: Add go-github-com-pkg-profile.

Message ID 20231018093836.2056-20-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-pkg-profile): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e1fa16e895..0a213c71b4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2173,6 +2173,30 @@  (define-public go-github-com-felixge-fgprof
 [Off-CPU](@@url{http://www.brendangregg.com/offcpuanalysis.html,http://www.brendangregg.com/offcpuanalysis.html})
 (e.g. I/O) time together.")
     (license license:expat)))
+
+(define-public go-github-com-pkg-profile
+  (package
+    (name "go-github-com-pkg-profile")
+    (version "1.7.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pkg/profile")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0ifr9gnycjwh7dbvsb5vgs9kzlr548cb4m45zvl8i8lgd3qhppy1"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/pkg/profile"))
+    (propagated-inputs `(("go-github-com-felixge-fgprof" ,go-github-com-felixge-fgprof)))
+    (home-page "https://github.com/pkg/profile")
+    (synopsis "profile")
+    (description
+     "Package profile provides a simple way to manage runtime/pprof profiling of your
+Go application.")
+    (license license:bsd-2)))
 (define-public go-github-com-pkg-xattr
   (package
     (name "go-github-com-pkg-xattr")