diff mbox series

[bug#66603,28/29] gnu: Add go-github-com-delthas-go-libnp.

Message ID 20231018093836.2056-28-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-delthas-go-libnp): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 76f074a932..6591297279 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11246,6 +11246,30 @@  (define-public go-github-com-godbus-dbus
 bindings for the D-Bus message bus system.")
     (license license:bsd-2)))
 
+(define-public go-github-com-delthas-go-libnp
+  (let ((commit "0e45ece1f878f202fee2c74801e287804668f677"))
+    (package
+      (name "go-github-com-delthas-go-libnp")
+      (version (git-version "0.0.0" "0" commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/delthas/go-libnp")
+                       (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                  (base32
+                    "1hylpvwz3kb8wr00knba6mggjacak2vmqafwysansj0ns038lp8w"))))
+      (build-system go-build-system)
+      (arguments `(#:import-path "github.com/delthas/go-libnp"))
+      (propagated-inputs (list go-github-com-godbus-dbus))
+      (home-page "https://github.com/delthas/go-libnp")
+      (synopsis "Tiny library providing information about now-playing media")
+      (description "@code{go-libnp} is a tiny cross-platform library for
+extracting information about the music/image/video that is Now Playing on the
+system.")
+      (license license:expat))))
+
 (define-public go-github-com-prometheus-common
   (package
     (name "go-github-com-prometheus-common")