diff mbox series

[bug#66603,05/29] gnu: Add go-github-com-johnkerl-lumin-colors.

Message ID 20231018093836.2056-5-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-johnkerl-lumin-colors): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d0caed8d41..178599c7fc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6196,6 +6196,32 @@  (define-public go-gitlab-com-ambrevar-damerau
 similar word.")
       (license license:expat))))
 
+(define-public go-github-com-johnkerl-lumin-colors
+  (package
+    (name "go-github-com-johnkerl-lumin-colors")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/johnkerl/lumin")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1liv27pxi79q4yr1bd0wgsx31ixw53ipsgs2kp0asxj2d6z4hpiz"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/johnkerl/lumin/pkg/colors"
+      #:unpack-path "github.com/johnkerl/lumin"))
+    (home-page "https://github.com/johnkerl/lumin")
+    (synopsis "lumin")
+    (description
+     "@@code{lumin} is a simple command-line program which highlights matches to a
+specified pattern (string or regex) in the specified files.  This is like
+@@code{grep} with @@code{--color}, except that @@code{lumin} shows all lines,
+not just matching lines.")
+    (license license:bsd-2)))
 (define-public misspell
   (package
     (name "misspell")