diff mbox series

[bug#66603,13/29] gnu: Add go-github-com-gobwas-httphead.

Message ID 20231018093836.2056-13-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-gobwas-httphead): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6ac749f274..e0fa50c2da 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1995,6 +1995,29 @@  (define-public go-github-com-chromedp-sysutil
     (description
      "Package sysutil provides some utilities for working with cross platform systems.")
     (license license:expat)))
+
+(define-public go-github-com-gobwas-httphead
+  (package
+    (name "go-github-com-gobwas-httphead")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/gobwas/httphead")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "106l8ml5yihld3rrf45q5fhlsx64hrpj2dsvnnm62av4ya5nf0gb"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/gobwas/httphead"))
+    (home-page "https://github.com/gobwas/httphead")
+    (synopsis "httphead.")
+    (description
+     "Package httphead contains utils for parsing HTTP and HTTP-grammar compatible
+text protocols headers.")
+    (license license:expat)))
 (define-public go-github-com-pkg-xattr
   (package
     (name "go-github-com-pkg-xattr")