diff mbox series

[bug#66603,16/29] gnu: Add go-github-com-josharian-intern.

Message ID 20231018093836.2056-16-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-josharian-intern): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 137855bbee..c6287c979f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2066,6 +2066,30 @@  (define-public go-github-com-gobwas-ws
      "Package ws implements a client and server for the @code{WebSocket} protocol as
 specified in @@url{https://rfc-editor.org/rfc/rfc6455.html,RFC 6455}.")
     (license license:expat)))
+
+(define-public go-github-com-josharian-intern
+  (package
+    (name "go-github-com-josharian-intern")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/josharian/intern")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1za48ppvwd5vg8vv25ldmwz1biwpb3p6qhf8vazhsfdg9m07951c"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/josharian/intern"))
+    (home-page "https://github.com/josharian/intern")
+    (synopsis #f)
+    (description
+     "Package intern interns strings.  Interning is best effort only.  Interned
+strings may be removed automatically at any time without notification.  All
+functions may be called concurrently with themselves and each other.")
+    (license license:expat)))
 (define-public go-github-com-pkg-xattr
   (package
     (name "go-github-com-pkg-xattr")