mbox series

[bug#66603,00/29] Add miller.

Message ID 20231018093521.1874-1-w@wmeyer.eu
Headers show
Series Add miller. | expand

Message

Wilko Meyer Oct. 18, 2023, 9:35 a.m. UTC
Hi Guix,

This patch series adds miller, a general purpose CLI tool for text
processing/manipulation, and its respective dependencies (while also
bumping a few packages to new versions).

Wilko Meyer (29):
  gnu: Add go-github-com-lestrrat-go-envload.
  gnu: Add go-github-com-lestrrat-go-strftime.
  gnu: Add go-github-com-ledongthuc-pdf.
  gnu: Add go-github-com-orisano-pixelmatch.
  gnu: Add go-github-com-johnkerl-lumin-colors.
  gnu: Add go-github-com-chromedp-chromedp.
  gnu: Add go-github-com-chzyer-test.
  gnu: Add go-github-com-chzyer-logex.
  gnu: Add go-github-com-chzyer-readline.
  gnu: Add go-github-com-ianlancetaylor-demangle.
  gnu: Add go-github-com-chromedp-cdproto.
  gnu: Add go-github-com-chromedp-sysutil.
  gnu: Add go-github-com-gobwas-httphead.
  gnu: Add go-github-com-gobwas-pool.
  gnu: Add go-github-com-gobwas-ws.
  gnu: Add go-github-com-josharian-intern.
  gnu: Add go-github-com-mailru-easyjson.
  gnu: Add go-github-com-google-pprof.
  gnu: Add go-github-com-felixge-fgprof.
  gnu: Add go-github-com-pkg-profile.
  gnu: Add go-golang-org-x-text.
  gnu: Add go-github-com-johnkerl-miller.
  gnu: Add miller.
  gnu: Add go-github-com-kballard-go-shellquote.
  gnu: Add go-github-com-facette-natsort.
  gnu: go-github-com-fatih-color: Update to 6.0.0.
  gnu: go-github-com-godbus-dbus: Update to 5.1.0.
  gnu: Add go-github-com-delthas-go-libnp.
  gnu: Add go-github-com-delthas-go-localeinfo.

 gnu/packages/golang.scm | 667 +++++++++++++++++++++++++++++++++++++++-
 1 file changed, 663 insertions(+), 4 deletions(-)

Comments

Sharlatan Hellseher Feb. 13, 2024, 7:35 p.m. UTC | #1
Hi,

Thank you for the patches.

I started reviewing procedure.

Most of them look like not touched or checked after guix import.

May you extend synopsis to one sentence and make sure
 descriptions have some more text.

Thanks,
Oleg
Sharlatan Hellseher April 9, 2024, 4:22 p.m. UTC | #2
Hi,

I've reviewed and pushed 5 of 29 preposal patches. Not some of not
accepted patches were already availalbe in Guix or not required to build
Miller.

Detailed list of modifications:

- accepted-patches [6/6]
  1. [X] [PATCH 05/29] gnu: Add go-github-com-johnkerl-lumin-colors.
     - Place to golang-xyz
     - Rename to go-github-com-johnkerl-lumin
     - Adjust synopsis and description
  2. [X] [PATCH 22/29] gnu: Add go-github-com-johnkerl-miller. [11/11]
     - Update to the latest version 6.12.0
     - Build man pages
     - Adjust homepage
     - Adjust synopsis and description
     - [X] go-github-com-facette-natsort
     - [X] go-github-com-johnkerl-lumin
     - [X] go-github-com-kballard-go-shellquote
     - [X] go-github-com-klauspost-compress
     - [X] go-github-com-lestrrat-go-strftime
       - [X] go-github-com-lestrrat-go-envload
       - [X] go-github-com-pkg-errors
       - [X] go-github-com-stretchr-testify
     - [X] go-github-com-mattn-go-isatty
     - [X] go-github-com-pkg-profile
     - [X] go-github-com-stretchr-testify
     - [X] go-golang-org-x-sys
     - [X] go-golang-org-x-term
     - [X] go-golang-org-x-text
  3. [X] [PATCH 01/29] gnu: Add go-github-com-lestrrat-go-envload.
     - Enable tests
     - Adjust synopsis and description
     - Place to golang-xyz
  4. [X] [PATCH 02/29] gnu: Add go-github-com-lestrrat-go-strftime.
     - Place to golang-xyz
     - Enable tests
     - Remove input lables
     - Adjust synopsis and description
     - Remove benchmarks
  5. [X] [PATCH 23/29] gnu: Add miller.
     - Squash with [PATCH 22/29] gnu: Add go-github-com-johnkerl-miller.
  6. [X] [PATCH 25/29] gnu: Add go-github-com-facette-natsort.
     - Place to golang-xyz
     - Adjust Synopsis
     - Add ref link to web.archive.org <https://web.archive.org/web/20210803201519/http://davekoelle.com/alphanum.html>

- rejected-patches [5/20]
  - [ ] [PATCH 03/29] gnu: Add go-github-com-ledongthuc-pdf.
    - Not required as go-github-com-google-pprof does not need it anymore.
  - [ ] [PATCH 04/29] gnu: Add go-github-com-orisano-pixelmatch.
  - [ ] [PATCH 06/29] gnu: Add go-github-com-chromedp-chromedp.
  - [ ] [PATCH 07/29] gnu: Add go-github-com-chzyer-test.
  - [ ] [PATCH 08/29] gnu: Add go-github-com-chzyer-logex.
  - [ ] [PATCH 09/29] gnu: Add go-github-com-chzyer-readline.
  - [ ] [PATCH 10/29] gnu: Add go-github-com-ianlancetaylor-demangle.
  - [ ] [PATCH 11/29] gnu: Add go-github-com-chromedp-cdproto.
  - [ ] [PATCH 12/29] gnu: Add go-github-com-chromedp-sysutil.
  - [ ] [PATCH 13/29] gnu: Add go-github-com-gobwas-httphead.
  - [ ] [PATCH 14/29] gnu: Add go-github-com-gobwas-pool.
  - [ ] [PATCH 15/29] gnu: Add go-github-com-gobwas-ws.
  - [ ] [PATCH 16/29] gnu: Add go-github-com-josharian-intern.
  - [ ] [PATCH 17/29] gnu: Add go-github-com-mailru-easyjson.
  - [ ] [PATCH 18/29] gnu: Add go-github-com-google-pprof. [0/11]
    - gnu: Add go-github-com-google-pprof.
      91709fa44255f3281eca787b573dde9777eacd1d
      Author:     Fries <fries1234@protonmail.com>
      AuthorDate: Sat Aug 5 11:01:42 2023 +0000
      Commit:     Sharlatan Hellseher <sharlatanus@gmail.com>
      CommitDate: Sat Apr 6 13:14:42 2024 +0100

     The minimal version was added, without chromedbp
    - [ ] go-github-com-chromedp-cdproto
    - [ ] go-github-com-chromedp-chromedp [0/5]
      - [ ] go-github-com-orisano-pixelmatch
      - [ ] go-github-com-mailru-easyjson
      - [ ] go-github-com-ledongthuc-pdf
      - [ ] go-github-com-gobwas-ws
      - [ ] go-github-com-chromedp-cdproto
    - [ ] go-github-com-chromedp-sysutil
    - [ ] go-github-com-chzyer-readline
    - [ ] go-github-com-gobwas-httphead
    - [ ] go-github-com-gobwas-pool
    - [ ] go-github-com-gobwas-ws
    - [ ] go-github-com-ianlancetaylor-demangle
    - [ ] go-github-com-josharian-intern
    - [ ] go-github-com-mailru-easyjson
    - [ ] go-golang-org-x-sys
  - [X] [PATCH 19/29] gnu: Add go-github-com-felixge-fgprof. [2/2]
    - gnu: Add go-github-com-felixge-fgprof.
      c973dc2d64212d814eabce734a5694f896e78f76
      Author:     Fries <fries1234@protonmail.com>
      AuthorDate: Sat Aug 5 11:01:47 2023 +0000
    - [X] go-github-com-stretchr-testify
    - [X] go-github-com-google-pprof
  - [X] [PATCH 20/29] gnu: Add go-github-com-pkg-profile. [1/1]
    - gnu: Add go-github-com-pkg-profile.
      e6efce9d4b760db544cfa0bd92bc6ab553d4b5f9
      Author:     Fries <fries1234@protonmail.com>
      AuthorDate: Sat Aug 5 11:01:51 2023 +0000
    - [X] go-github-com-felixge-fgprof
  - [X] [PATCH 21/29] gnu: Add go-golang-org-x-text.
    - gnu: Add go-golang-org-x-text-encoding.
      06c2d0e6c1f8c6d79daeb7991087b9eff388b28c
      Author:     Brian Leung <bkleung89@gmail.com>
      AuthorDate: Tue Jun 25 20:42:49 2019 +0200
      CommitDate: Mon Jul 29 16:08:18 2019 +0200

      Eventually it became go-golang-org-x-text
  - [X] [PATCH 24/29] gnu: Add go-github-com-kballard-go-shellquote.
    - gnu: Add go-github-com-kballard-go-shellquote.
      89d91ee2a04c286c442aa8636fafe7b7a85107df
      Author:     Leo Famulari <leo@famulari.name>
      AuthorDate: Wed Oct 11 20:20:40 2017 -0400
  - [X] [PATCH 28/29] gnu: Add go-github-com-delthas-go-libnp.
    - Added from https://issues.guix.gnu.org/64222

Pushed as 4d1079b9c9..e8d3d5224e to master.

--
Oleg