diff mbox series

[bug#66603,15/29] gnu: Add go-github-com-gobwas-ws.

Message ID 20231018093836.2056-15-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-gobwas-ws): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7a30ead05a..137855bbee 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2040,6 +2040,32 @@  (define-public go-github-com-gobwas-pool
     (description
      "Package pool contains helpers for pooling structures distinguishable by size.")
     (license license:expat)))
+
+(define-public go-github-com-gobwas-ws
+  (package
+    (name "go-github-com-gobwas-ws")
+    (version "1.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/gobwas/ws")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "122bmdc194819n8k3qq825y9q3am43xcgk4aixp13d8778fk9l1f"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/gobwas/ws"))
+    (propagated-inputs `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
+                         ("go-github-com-gobwas-pool" ,go-github-com-gobwas-pool)
+                         ("go-github-com-gobwas-httphead" ,go-github-com-gobwas-httphead)))
+    (home-page "https://github.com/gobwas/ws")
+    (synopsis "ws")
+    (description
+     "Package ws implements a client and server for the @code{WebSocket} protocol as
+specified in @@url{https://rfc-editor.org/rfc/rfc6455.html,RFC 6455}.")
+    (license license:expat)))
 (define-public go-github-com-pkg-xattr
   (package
     (name "go-github-com-pkg-xattr")