diff mbox series

[bug#66603,19/29] gnu: Add go-github-com-felixge-fgprof.

Message ID 20231018093836.2056-19-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-felixge-fgprof): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2fe4443ce0..e1fa16e895 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2147,6 +2147,32 @@  (define-public go-github-com-google-pprof
      "pprof is a tool for collection, manipulation and visualization of performance
 profiles.")
     (license license:asl2.0)))
+
+(define-public go-github-com-felixge-fgprof
+  (package
+    (name "go-github-com-felixge-fgprof")
+    (version "0.9.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/felixge/fgprof")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "03q3vnjd13r944y2qvfncs21lfkgmg0y8z14zz0xda1hz490wha3"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/felixge/fgprof"))
+    (propagated-inputs `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+                         ("go-github-com-google-pprof" ,go-github-com-google-pprof)))
+    (home-page "https://github.com/felixge/fgprof")
+    (synopsis "🚀 fgprof - The Full Go Profiler")
+    (description
+     "fgprof is a sampling Go profiler that allows you to analyze On-CPU as well as
+[Off-CPU](@@url{http://www.brendangregg.com/offcpuanalysis.html,http://www.brendangregg.com/offcpuanalysis.html})
+(e.g. I/O) time together.")
+    (license license:expat)))
 (define-public go-github-com-pkg-xattr
   (package
     (name "go-github-com-pkg-xattr")