diff mbox series

[bug#66603,24/29] gnu: Add go-github-com-kballard-go-shellquote.

Message ID 20231018093836.2056-24-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-kballard-go-shellquote): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bf5caf9c2c..166270d201 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8766,6 +8766,29 @@  (define-public go-github-com-shirou-gopsutil
       (home-page "https://github.com/shirou/gopsutil")
       (license license:bsd-3))))
 
+(define-public go-github-com-kballard-go-shellquote
+  (package
+    (name "go-github-com-kballard-go-shellquote")
+    (version "0.0.0-20180428030007-95032a82bc51")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/kballard/go-shellquote")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1rspvmnsikdq95jmx3dykxd4k1rmgl98ryjrysvl0cf18hl1vq80"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/kballard/go-shellquote"))
+    (home-page "https://github.com/kballard/go-shellquote")
+    (synopsis #f)
+    (description
+     "Shellquote provides utilities for joining/splitting strings using sh's
+word-splitting rules.")
+    (license license:expat)))
+
 (define-public go-github-com-danwakefield-fnmatch
   (let ((commit "cbb64ac3d964b81592e64f957ad53df015803288")
         (revision "0"))