diff mbox series

[bug#66603,22/29] gnu: Add go-github-com-johnkerl-miller.

Message ID 20231018093836.2056-22-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-johnkerl-miller): New variable.
---
 gnu/packages/golang.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 91839a53ec..0c11ac368a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6628,6 +6628,43 @@  (define-public go-github-com-johnkerl-lumin-colors
 @@code{grep} with @@code{--color}, except that @@code{lumin} shows all lines,
 not just matching lines.")
     (license license:bsd-2)))
+
+(define-public go-github-com-johnkerl-miller
+  (package
+    (name "go-github-com-johnkerl-miller")
+    (version "6.9.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/johnkerl/miller")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1xg6sk71madqy79qksvymi8hlmqrsb72yxi53hsjlmypdk33v1q7"))))
+    (build-system go-build-system)
+      (propagated-inputs
+       (list go-github-com-certifi-gocertifi
+             go-golang-org-x-text
+             go-github-com-facette-natsort
+             go-github-com-johnkerl-lumin-colors
+             go-github-com-kballard-go-shellquote
+             go-github-com-klauspost-compress
+             go-github-com-lestrrat-go-strftime
+             go-github-com-mattn-go-isatty
+             go-github-com-pkg-profile
+             go-golang-org-x-term
+             go-github-com-pkg-errors))
+    (arguments
+     (list
+      #:import-path "github.com/johnkerl/miller/cmd/mlr"
+      #:unpack-path "github.com/johnkerl/miller"))
+    (home-page "https://github.com/johnkerl/miller")
+    (synopsis "general-purpose cli data processing tool")
+    (description
+     "Like awk, sed, cut, join, and sort for data formats such as
+CSV, TSV, JSON, JSON Lines, and positionally-indexed")
+    (license license:bsd-2)))
 (define-public misspell
   (package
     (name "misspell")