diff mbox series

[bug#66603,12/29] gnu: Add go-github-com-chromedp-sysutil.

Message ID 20231018093836.2056-12-w@wmeyer.eu
State New
Headers show
Series Add miller. | expand

Commit Message

Wilko Meyer Oct. 18, 2023, 9:38 a.m. UTC
* gnu/packages/golang.scm (go-github-com-chromedp-sysutil): New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6eda7bbc2e..6ac749f274 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1973,6 +1973,28 @@  (define-public go-github-com-chromedp-cdproto
      "Package cdproto provides the Chrome @code{DevTools} Protocol commands, types,
 and events for the cdproto domain.")
     (license license:expat)))
+
+(define-public go-github-com-chromedp-sysutil
+  (package
+    (name "go-github-com-chromedp-sysutil")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/chromedp/sysutil")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0vczhxgnvfkw1h12rbyyllcgwa1rmhn5x4iq20sm7dld26rglh5b"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/chromedp/sysutil"))
+    (home-page "https://github.com/chromedp/sysutil")
+    (synopsis "About sysutil")
+    (description
+     "Package sysutil provides some utilities for working with cross platform systems.")
+    (license license:expat)))
 (define-public go-github-com-pkg-xattr
   (package
     (name "go-github-com-pkg-xattr")