diff mbox series

[bug#55903,09/41] gnu: Add go-github-com-go-ini-ini.

Message ID 20220611191653.15471-9-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-github-com-go-ini-ini): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

M June 11, 2022, 10:45 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> +(define-public go-github-com-go-ini-ini
> +  (package
> +    (name "go-github-com-go-ini-ini")
> +    (version "1.66.6")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/go-ini/ini")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "0kqg13606hnw8f75cb59fsy1m85kiqf3csi2g7q2512avdmaphc9"))))

From a distance, these look like the same thing as go-gopkg-in-ini-v1
or go-gopkg-in-ini?  Why the new definition.

Greetings,
Maxime
\( June 12, 2022, 10:34 a.m. UTC | #2
On Sat Jun 11, 2022 at 11:45 PM BST, Maxime Devos wrote:
> From a distance, these look like the same thing as go-gopkg-in-ini-v1
> or go-gopkg-in-ini?  Why the new definition.

Yes, they are the same (with different versions). aerc's source code uses
the github.com import path, though. I'll replace that package with one
inherited from go-gopkg-in-ini and modified to use the github import path.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 648ad7956d..e0f5039803 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10030,3 +10030,26 @@  (define-public go-github-com-kyoh86-xdg
      "Package xdg provides lightweight helper functions in golang to get config,
 data and cache directories according to the XDG Base Directory Specification")
     (license license:expat)))
+
+(define-public go-github-com-go-ini-ini
+  (package
+    (name "go-github-com-go-ini-ini")
+    (version "1.66.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/go-ini/ini")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0kqg13606hnw8f75cb59fsy1m85kiqf3csi2g7q2512avdmaphc9"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/go-ini/ini"))
+    (propagated-inputs (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/go-ini/ini")
+    (synopsis "INI support for Go")
+    (description
+     "Package ini provides INI file read and write functionality in Go.")
+    (license license:asl2.0)))