diff mbox series

[bug#55903,02/41] gnu: Add go-github-com-creack-pty.

Message ID 20220611191653.15471-2-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-github-com-creack-pty): New variable.

Signed-off-by: (unmatched-parenthesis <paren@disroot.org>
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

M June 11, 2022, 10:30 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> +(define-public go-github-com-creack-pty
> +  (package
> +    (name "go-github-com-creack-pty")
> +    (version "1.1.18")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/creack/pty")

This contains generated files:

https://github.com/creack/pty/blob/master/ztypes_freebsd_arm.go

Please delete, regenerate and check the other new packages as well.

Greetings,
MAxime.
M June 11, 2022, 10:32 p.m. UTC | #2
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> +     "Package pty provides functions for working with Unix pseudoterminals.")

Not grammatical, add ‘The’ before ‘Package’.  Also check other
packages.

Greetings,
Maxime.
M June 11, 2022, 10:35 p.m. UTC | #3
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> Signed-off-by: (unmatched-parenthesis <paren@disroot.org>

That's not how we use that in Guix -- search in the manual for
Signed-off-by.
M June 11, 2022, 10:38 p.m. UTC | #4
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> * gnu/packages/golang.scm (go-github-com-creack-pty): New variable.

In the previous patch series, ‘go-git-sr-ht-sircmpwn-pty’ was used
instead.  What is the reason for changing it in the new version of the
patch series?  Likewise, why the change from sircmpwn/aerc to
~rjarry/aerc?  Likewise for other packages.  Likewise, why has the
'wrap-program' been dropped in aerc?  Please mention such things in the
cover letter.

https://issues.guix.gnu.org/37444#55

Greetings,
Maxime.
\( June 12, 2022, 10:19 a.m. UTC | #5
On Sat Jun 11, 2022 at 11:30 PM BST, Maxime Devos wrote:
> This contains generated files:
>
> https://github.com/creack/pty/blob/master/ztypes_freebsd_arm.go
>
> Please delete, regenerate and check the other new packages as well.

Good catch, thanks!
\( June 12, 2022, 12:17 p.m. UTC | #6
On Sat Jun 11, 2022 at 11:35 PM BST, Maxime Devos wrote:
> That's not how we use that in Guix -- search in the manual for
> Signed-off-by.

Oops, forgot that we don't sign-off when I wrote that commit.
\( June 12, 2022, 12:18 p.m. UTC | #7
On Sat Jun 11, 2022 at 11:32 PM BST, Maxime Devos wrote:
> Not grammatical, add ‘The’ before ‘Package’.  Also check other
> packages.

As mentioned before, this pattern is extremely common in Go package
descriptions.
\( June 12, 2022, 12:33 p.m. UTC | #8
On Sat Jun 11, 2022 at 11:38 PM BST, Maxime Devos wrote:
> In the previous patch series, ‘go-git-sr-ht-sircmpwn-pty’ was used

Presumably sircmpwn-pty was a temporary fork done for one reason or
another. The go.mod now uses creack-pty.

> Likewise, why the change from sircmpwn/aerc to ~rjarry/aerc?

Drew DeVault stopped maintaining aerc, so rjarry forked it -.o.-

> Likewise, why has the 'wrap-program' been dropped in aerc?

Not sure why that wrap-program was there in the first place. Maybe
aerc invoked some ncurses program at one point? Strange thing to do.
Anyway, the PATH change isn't required anymore, so the wrap-program
isn't either. aerc *does* invoke colordiff for displaying some
messages, but I'm pretty sure that invoked programs shouldn't 

> Please mention such things in the cover letter.

This patchset was actually done from scratch; I didn't include any
of the original code, and I hadn't actually looked at it, since aerc
has changed quite a lot.
M June 12, 2022, 1 p.m. UTC | #9
( schreef op zo 12-06-2022 om 13:33 [+0100]:
> This patchset was actually done from scratch; I didn't include any
> of the original code, and I hadn't actually looked at it, since aerc
> has changed quite a lot.

Ok.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 01afa786ba..7570ce6c6f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9861,3 +9861,25 @@  (define-public go-github-com-zenhack-go-notmuch
     (description "Package notmuch provides a Go language binding to the notmuch
 email library.")
     (license license:gpl3+)))
+
+(define-public go-github-com-creack-pty
+  (package
+    (name "go-github-com-creack-pty")
+    (version "1.1.18")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/creack/pty")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1qqhcgfym0napz8damj7dhfw28g2qn2f5h3lr93i0sxawq926yzc"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/creack/pty"))
+    (home-page "https://github.com/creack/pty")
+    (synopsis "Pseudoterminal handling in Go")
+    (description
+     "Package pty provides functions for working with Unix pseudoterminals.")
+    (license license:expat)))