diff mbox series

[bug#55903,05/41] gnu: Add go-github-com-xo-terminfo.

Message ID 20220611191653.15471-5-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-github-com-xo-terminfo): New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

M June 11, 2022, 10:41 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> immplemented in pure Go

Guix is not a language-specific package manager, it supports working
with multiple languages at the same time, so mentioning ‘it doesn't use
dependencies in other languages’ is usually irrelevant in Guix.

Greetings,
Maxime.
M June 11, 2022, 10:44 p.m. UTC | #2
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> +(define-public go-github-com-xo-terminfo
> +  (package
> +    (name "go-github-com-xo-terminfo")
> +    (version "0.0.0-20210125001918-ca9a967f8778")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/xo/terminfo")
> +                    (commit (go-version->git-ref version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "05gdcvcbwcrcwxznhvs1q1xh4irz2d10v2mz179pydjh30kjc0j5"))))

Are the tests actually run?  There's a neetwork-accessing test in
https://github.com/miolini/datacounter/blob/master/response_writer_test.go
so something weird seems to be going on.

Greetings,
Maxime.
\( June 12, 2022, 10:28 a.m. UTC | #3
On Sat Jun 11, 2022 at 11:41 PM BST, Maxime Devos wrote:
> Guix is not a language-specific package manager, it supports working
> with multiple languages at the same time, so mentioning ‘it doesn't use
> dependencies in other languages’ is usually irrelevant in Guix.

Okay, I'll change that (and fix the typo ;)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index aaa9f79012..b4fc3ed2b9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9936,3 +9936,25 @@  (define-public go-google-golang-org-appengine
      "Package appengine provides basic functionality for running Go on
 Google App Engine.")
     (license license:asl2.0)))
+
+(define-public go-github-com-xo-terminfo
+  (package
+    (name "go-github-com-xo-terminfo")
+    (version "0.0.0-20210125001918-ca9a967f8778")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/xo/terminfo")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "05gdcvcbwcrcwxznhvs1q1xh4irz2d10v2mz179pydjh30kjc0j5"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/xo/terminfo"))
+    (home-page "https://github.com/xo/terminfo")
+    (synopsis "Read the terminfo database in Go")
+    (description
+     "Package terminfo implements terminfo database reading in pure Go.")
+    (license license:expat)))