diff mbox series

[bug#55903,04/41] gnu: Add go-google-golang-org-appengine.

Message ID 20220611191653.15471-4-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-google-golang-org-appengine): New
  variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

M June 11, 2022, 10:28 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> +    (description
> +     "Package appengine provides basic functionality for running Go on
> +Google App Engine.")

Guix does not run on Google App Engine AFAIK, so no need to include
this package.

Greetings,
Maxime.
\( June 12, 2022, 10:27 a.m. UTC | #2
On Sat Jun 11, 2022 at 11:28 PM BST, Maxime Devos wrote:
> Guix does not run on Google App Engine AFAIK, so no need to include
> this package.

The official descriptions of this package are extraordinarily vague, so this
was my best attempt at estimating what it's for. Seems like it's never imported
in the source code of aerc... I wonder why it's in go.mod. I'll ask #aerc
about this one.
\( June 12, 2022, 12:34 p.m. UTC | #3
On Sat Jun 11, 2022 at 11:28 PM BST, Maxime Devos wrote:
> Guix does not run on Google App Engine AFAIK, so no need to include
> this package.

Tested it without the appengine package in inputs, and it builds fine,
so I'll remove that one :)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a39b5e5cd2..aaa9f79012 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9911,3 +9911,28 @@  (define-public go-google-golang-org-protobuf-proto
 is a language-neutral, platform-neutral, extensible mechanism for serializing
 structured data.")
     (license license:bsd-3)))
+
+(define-public go-google-golang-org-appengine
+  (package
+    (name "go-google-golang-org-appengine")
+    (version "1.6.7")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/golang/appengine")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1wkipg7xxc0ha5p6c3bj0vpgq38l18441n5l6zxdhx0gzvz5z1hs"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "google.golang.org/appengine"))
+    (propagated-inputs (list go-golang-org-x-text go-golang-org-x-net
+                             go-github-com-golang-protobuf-proto))
+    (home-page "https://google.golang.org/appengine")
+    (synopsis "Go runtime on Google App Engine")
+    (description
+     "Package appengine provides basic functionality for running Go on
+Google App Engine.")
+    (license license:asl2.0)))