diff mbox series

[bug#55903,37/41] gnu: Add go-github-com-google-shlex.

Message ID 20220611191653.15471-37-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-github-com-google-shlex): New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

M June 11, 2022, 10:20 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> +    (version "v0.0.0-20181106134648-c34317bd91bf")

No need to keep v prefixes in the Guix version.

Greetings,
Maxime.
M June 11, 2022, 10:21 p.m. UTC | #2
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> * gnu/packages/golang.scm (go-github-com-google-shlex): New variable.

See <https://issues.guix.gnu.org/47539#28>.
\( June 12, 2022, 10:47 a.m. UTC | #3
On Sat Jun 11, 2022 at 11:20 PM BST, Maxime Devos wrote:
> No need to keep v prefixes in the Guix version.

Oops! Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1e570584ab..bd22e7ff44 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10679,3 +10679,25 @@  (define-public go-github-com-lithammer-fuzzysearch
      "A speedy fuzzy matching package for Go inspired by the JavaScript
 library bevacqua/fuzzysearch.")
     (license license:expat)))
+
+(define-public go-github-com-google-shlex
+  (package
+    (name "go-github-com-google-shlex")
+    (version "v0.0.0-20181106134648-c34317bd91bf")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/google/shlex")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "00qivza4hkllfkar2vpqmyxybi0fwqipgijv61dgapq4xddxdq0r"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/google/shlex"))
+    (home-page "https://github.com/google/shlex")
+    (synopsis "Simple lexer for Go")
+    (description "Shlex is a simple lexer for Go that supports shell-style
+quoting, commenting, and escaping.")
+    (license license:asl2.0)))