diff mbox series

[bug#55903,15/41] gnu: Add go-github-com-jaytaylor-html2text.

Message ID 20220611191653.15471-15-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-github-com-jaytaylor-html2text): New
  variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

M June 11, 2022, 10:48 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> Ensure
> +your emails are readable by all!"

Rather markety.  Also: ensure->It ensures that.


Greetings,
Maxime.
M June 11, 2022, 10:49 p.m. UTC | #2
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> +           ;; XXX: Seems to make incorrect assertions about the text it produces?

Please add a link to the upstream bug report, such that future updaters
of the package can easily check whether the issue has been resolved and
hence whether tests can be re-enabled, and such that reviewers can
evaluate whether the bug is likely to be a problem for users.
Likewise for all other new package disabling tests, if any.

Greetings,
Maxime.
\( June 12, 2022, 10:35 a.m. UTC | #3
On Sat Jun 11, 2022 at 11:48 PM BST, Maxime Devos wrote:
> Rather markety.  Also: ensure->It ensures that.

Fair enough; this was the description I got when I `guix import`ed it.
\( June 12, 2022, 10:36 a.m. UTC | #4
On Sat Jun 11, 2022 at 11:49 PM BST, Maxime Devos wrote:
> Please add a link to the upstream bug report, such that future updaters
> of the package can easily check whether the issue has been resolved and
> hence whether tests can be re-enabled, and such that reviewers can
> evaluate whether the bug is likely to be a problem for users.
> Likewise for all other new package disabling tests, if any.

Here's the bug report: <https://github.com/jaytaylor/html2text/issues/53>. I'll
add that link to the comment.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8caf840ae2..4f6770358f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10179,3 +10179,31 @@  (define-public go-github-com-gogs-chardet
     (description "Package chardet ports character set detection from ICU
 to Go.")
     (license license:expat)))
+
+(define-public go-github-com-jaytaylor-html2text
+  (package
+    (name "go-github-com-jaytaylor-html2text")
+    (version "0.0.0-20211105163654-bc68cce691ba")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jaytaylor/html2text")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "12ckgkp8xqgp0fh6019nwp4ssg2k1rv1a67cpk37ian4q5zrvppm"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/jaytaylor/html2text"
+           ;; XXX: Seems to make incorrect assertions about the text it produces?
+           #:tests? #f))
+    (propagated-inputs (list go-golang-org-x-net
+                             go-github-com-olekukonko-tablewriter
+                             go-github-com-ssor-bom))
+    (home-page "https://github.com/jaytaylor/html2text")
+    (synopsis "Convert HTML email to text")
+    (description
+     "Package html2text converts HTML emails to textual ones.  Ensure
+your emails are readable by all!")
+    (license license:expat)))