diff mbox series

[bug#55903,20/41] gnu: Add go-github-com-emersion-go-textwrapper.

Message ID 20220611191653.15471-20-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-github-com-emersion-go-textwrapper): New
  variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 14fc8385d7..8a5c566a08 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10318,3 +10318,26 @@  (define-public go-github-com-gatherstars-com-jwz
 created by Jamie Zawinski and explained by him at
 @url{https://www.jwz.org/doc/threading.html,https://www.jwz.org/doc/threading.html}.")
     (license license:asl2.0)))
+
+(define-public go-github-com-emersion-go-textwrapper
+  (package
+    (name "go-github-com-emersion-go-textwrapper")
+    (version "0.0.0-20200911093747-65d896831594")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emersion/go-textwrapper")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1lh9d7zvj6gm1rr6sv5xlagklgx9d666hq5srd37a4sdcjkbiqmq"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/emersion/go-textwrapper"))
+    (home-page "https://github.com/emersion/go-textwrapper")
+    (synopsis "Text-wrapping writer for Go")
+    (description
+     "This package provides a writer that wraps long text lines to a specified
+length.")
+    (license license:expat)))