diff mbox series

[bug#55903,19/41] gnu: Add go-github-com-gatherstars-com-jwz.

Message ID 20220611191653.15471-19-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-github-com-gatherstars-com-jwz): New
  variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

M June 11, 2022, 10:57 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
>
> [...] created by Jamie Zawinski and explained by him at

Packages are packaged in Guix for the convenience of the user, not for
making the author of the software popular.  Instead, maybe you could
write a _short_ description on what threading is, what things are taken
in account (In-Reply-To, References, ..), and maybe whether it scales
lineary or exponentially or whatever?

Greetings,
Maxime.
\( June 12, 2022, 10:39 a.m. UTC | #2
On Sat Jun 11, 2022 at 11:57 PM BST, Maxime Devos wrote:
> Packages are packaged in Guix for the convenience of the user, not for
> making the author of the software popular.  Instead, maybe you could
> write a _short_ description on what threading is, what things are taken
> in account (In-Reply-To, References, ..), and maybe whether it scales
> lineary or exponentially or whatever?

Okay, I'll look into it. (The official description doesn't have anything
like that; it just mentions that it's an email threading library using
jwz's algorithm.)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e16af75883..14fc8385d7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10291,3 +10291,30 @@  (define-public go-github-com-jhillyerd-enmime
 It's built on top of Go's included mime/multipart support where possible,
 but is geared towards parsing MIME encoded emails.")
     (license license:expat)))
+
+(define-public go-github-com-gatherstars-com-jwz
+  (package
+    (name "go-github-com-gatherstars-com-jwz")
+    (version "1.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/gatherstars-com/jwz")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1h37h5w139d3rhvp1n7kz2jm5zhk4pjzf3sip04v48nphkika60c"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/gatherstars-com/jwz"))
+    (propagated-inputs (list go-github-com-rivo-tview
+                             go-github-com-jhillyerd-enmime
+                             go-github-com-gdamore-tcell-v2))
+    (home-page "https://github.com/gatherstars-com/jwz")
+    (synopsis "JWZ's email threading algorithm implemented in Go")
+    (description
+     "Package jwz is an implementation of the email threading algorithm
+created by Jamie Zawinski and explained by him at
+@url{https://www.jwz.org/doc/threading.html,https://www.jwz.org/doc/threading.html}.")
+    (license license:asl2.0)))