diff mbox series

[bug#55903,03/41] gnu: Add go-google-golang-org-protobuf-proto.

Message ID 20220611191653.15471-3-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-google-golang-org-protobuf-proto): New
  variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

M June 11, 2022, 10:19 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> * gnu/packages/golang.scm (go-google-golang-org-protobuf-proto): New

We already have (a variant of) this:

go-github-com-gogo-protobuf description mentions: ‘goprotobuf
compatibility’ (not sure if that refers to API or serialisation format
though).

Or: go-github-com-golang-protobuf-proto (looks the same for a distance
except for domain name).

Greetings,
Maxime.
\( June 12, 2022, 10:23 a.m. UTC | #2
On Sat Jun 11, 2022 at 11:19 PM BST, Maxime Devos wrote:
> go-github-com-gogo-protobuf description mentions: ‘goprotobuf
> compatibility’ (not sure if that refers to API or serialisation format
> though).
> Or: go-github-com-golang-protobuf-proto (looks the same for a distance
> except for domain name).

They're not the same. From https://github.com/golang/protobuf:

> This module (github.com/golang/protobuf) contains Go bindings for protocol
> buffers. It has been superseded by the google.golang.org/protobuf module,
> which contains an updated and simplified API, support for protobuf reflection,
> and many other improvements. We recommend that new code use the
> google.golang.org/protobuf module.

and from https://github.com/gogo/protobuf:

> gogoprotobuf is a fork of golang/protobuf with extra code generation features.

which implies that it has golang/protobuf's API, which as mentioned above is not
the same as the google-golang-org one.
M June 12, 2022, 12:38 p.m. UTC | #3
( schreef op zo 12-06-2022 om 11:23 [+0100]:
> They're not the same. From https://github.com/golang/protobuf:
> 
> > This module (github.com/golang/protobuf) contains Go bindings for protocol
> > buffers. It has been superseded by the google.golang.org/protobuf module,
> > which contains an updated and simplified API, support for protobuf reflection,
> > and many other improvements. We recommend that new code use the
> > google.golang.org/protobuf module.
> 
> and from https://github.com/gogo/protobuf:

As these questions keeps popping up again, maybe this is info to put in
the package descriptions of go-github-com-gogo-protobuf, go-github-com-
golang-protobuf-proto and go-google-golang-org-protobuf-proto?

Greetings,
Maxime.
\( June 12, 2022, 12:43 p.m. UTC | #4
On Sun Jun 12, 2022 at 1:38 PM BST, Maxime Devos wrote:
> As these questions keeps popping up again, maybe this is info to put in
> the package descriptions of go-github-com-gogo-protobuf, go-github-com-
> golang-protobuf-proto and go-google-golang-org-protobuf-proto?

Good idea.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7570ce6c6f..a39b5e5cd2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9883,3 +9883,31 @@  (define-public go-github-com-creack-pty
     (description
      "Package pty provides functions for working with Unix pseudoterminals.")
     (license license:expat)))
+
+(define-public go-google-golang-org-protobuf-proto
+  (package
+    (name "go-google-golang-org-protobuf-proto")
+    (version "1.28.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://go.googlesource.com/protobuf")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1nzcc4qc00afi24nb7nlnwyzvvr6b8s8qdrn1sw085nygh2y2x8r"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "google.golang.org/protobuf/proto"
+           #:unpack-path "google.golang.org/protobuf"))
+    (propagated-inputs (list go-github-com-google-go-cmp-cmp
+                             go-github-com-golang-protobuf-proto))
+    (home-page "https://google.golang.org/protobuf")
+    (synopsis "Go support for Protocol Buffers")
+    (description
+     "This project hosts the Go implementation for
+@url{https://developers.google.com/protocol-buffers,protocol buffers}, which
+is a language-neutral, platform-neutral, extensible mechanism for serializing
+structured data.")
+    (license license:bsd-3)))