diff mbox series

[bug#55903,10/41] gnu: Add go-github-com-lucasb-eyer-go-colorful.

Message ID 20220611191653.15471-10-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-github-com-lucasb-eyer-go-colorful): New
  variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e0f5039803..a8e27ab22b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10053,3 +10053,29 @@  (define-public go-github-com-go-ini-ini
     (description
      "Package ini provides INI file read and write functionality in Go.")
     (license license:asl2.0)))
+
+(define-public go-github-com-lucasb-eyer-go-colorful
+  (package
+    (name "go-github-com-lucasb-eyer-go-colorful")
+    (version "1.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/lucasb-eyer/go-colorful")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "08c3fkf27r16izjjd4w94xd1z7w1r4mdalbl53ms2ka2j465s3qs"))))
+    (build-system go-build-system)
+    (inputs (list go-golang-org-x-image))
+    (arguments
+     (list #:import-path "github.com/lucasb-eyer/go-colorful"))
+    (home-page "https://github.com/lucasb-eyer/go-colorful")
+    (synopsis "Library for playing with colors in Go")
+    (description
+     "@code{go-github-com-lucasb-eyer-go-colorful} is a library for playing
+with colors in Go.  @code{go-github-com-lucasb-eyer-go-colorful} stores
+colors in RGB and provides methods for converting these to various color
+spaces.")
+    (license license:expat)))