diff mbox series

[bug#55903,21/41] gnu: Add go-github-com-emersion-go-message.

Message ID 20220611191653.15471-21-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-github-com-emersion-go-message): New
  variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

M June 11, 2022, 10:59 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> +     "Package message implements reading and writing multipurpose messages.")

This is rather vague -- what kind of messages?  Also grammer, a ‘the’
is missing before ‘Package’ and 'message'.  Maybe better: ‘This package
implements ...’.

Greetings,
Maxime
\( June 12, 2022, 10:41 a.m. UTC | #2
On Sat Jun 11, 2022 at 11:59 PM BST, Maxime Devos wrote:
> This is rather vague -- what kind of messages?

The Internet Message Format and MIME:
<https://github.com/emersion/go-message/blob/master/README.md>

> Also grammer, a ‘the’ is missing before ‘Package’ and 'message'.
> Maybe better: ‘This package implements ...’.

This is standard wording for Go package descriptions: "Package xxx
implements yyy". No, it doesn't make sense :)
M June 12, 2022, 12:59 p.m. UTC | #3
( schreef op zo 12-06-2022 om 11:41 [+0100]:
> This is standard wording for Go package descriptions: "Package xxx
> implements yyy". No, it doesn't make sense :)

This documentation bug is common.  That doesn't make it correct (*,**).
Even if it was standard, standard can be incorrect and subject to
improving.  If a practice doesn't make sense, then that practice needs
to be changed.

(*) Lack of an article is not incorrect per se, but we don't have space
limitations in the description field, so no need to compress the
description by leaving out articles.

(**) E.g., there is a wide-spread (standard?) cross-compilation bug in
the use of 'wrap-program', which is more often than not used
incorrectly, see <https://issues.guix.gnu.org/49327>.  This does not
make it somehow correct.

Greetings,
Maxime
\( June 12, 2022, 1:14 p.m. UTC | #4
On Sun Jun 12, 2022 at 1:59 PM BST, Maxime Devos wrote:
> This documentation bug is common.  That doesn't make it correct (*,**).
> Even if it was standard, standard can be incorrect and subject to
> improving.  If a practice doesn't make sense, then that practice needs
> to be changed.

Okay then. I'll change that wording.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8a5c566a08..883dfcbd20 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10341,3 +10341,27 @@  (define-public go-github-com-emersion-go-textwrapper
      "This package provides a writer that wraps long text lines to a specified
 length.")
     (license license:expat)))
+
+(define-public go-github-com-emersion-go-message
+  (package
+    (name "go-github-com-emersion-go-message")
+    (version "0.16.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emersion/go-message")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1j5qdhsna28xcs843zsiccw700rld5hin466dl0n3a0ax1w13ay0"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/emersion/go-message"))
+    (propagated-inputs (list go-golang-org-x-text
+                             go-github-com-emersion-go-textwrapper))
+    (home-page "https://github.com/emersion/go-message")
+    (synopsis "Multipurpose messages in Go")
+    (description
+     "Package message implements reading and writing multipurpose messages.")
+    (license license:expat)))