diff mbox series

[bug#55903,24/41] gnu: Add go-github-com-emersion-go-imap-sortthread.

Message ID 20220611191653.15471-24-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-github-com-emersion-go-imap-sortthread):
  New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

M June 11, 2022, 11:01 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> +    (synopsis "SORT and THREAD for go-imap")
> +    (description "Package sortthread implements SORT and THREAD for go-imap.")

This doesn't really explain anything, except that's it related to
sorting and imap.  Needs to be longer and explain what is meant by SORT
and THREAD.  Also, it's not named go-imap, but go-github-...-go-imap 
here.

Greetings,
Maxime.
\( June 12, 2022, 10:42 a.m. UTC | #2
On Sun Jun 12, 2022 at 12:01 AM BST, Maxime Devos wrote:
> This doesn't really explain anything, except that's it related to
> sorting and imap.  Needs to be longer and explain what is meant by SORT
> and THREAD.  Also, it's not named go-imap, but go-github-...-go-imap 
> here.

Noted...
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f579b63fb0..b66ded6f61 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10411,3 +10411,27 @@  (define-public go-github-com-emersion-go-imap
     (description "This package provides an IMAP4rev1 library written in
 Go.  It can be used to build IMAP clients and servers.")
     (license license:expat)))
+
+(define-public go-github-com-emersion-go-imap-sortthread
+  (package
+    (name "go-github-com-emersion-go-imap-sortthread")
+    (version "1.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emersion/go-imap-sortthread")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1cfbgz1l5angnj52v9pxwggai2shx0h78ffcp7j4r4lr7lzflnwz"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/emersion/go-imap-sortthread"))
+    (propagated-inputs (list go-golang-org-x-text
+                             go-github-com-emersion-go-sasl
+                             go-github-com-emersion-go-imap))
+    (home-page "https://github.com/emersion/go-imap-sortthread")
+    (synopsis "SORT and THREAD for go-imap")
+    (description "Package sortthread implements SORT and THREAD for go-imap.")
+    (license license:expat)))