diff mbox series

[bug#55903,18/41] gnu: Add go-github-com-jhillyerd-enmime.

Message ID 20220611191653.15471-18-paren@disroot.org
State New
Headers show
Series [bug#55903,01/41] gnu: Add go-github-com-zenhack-go-notmuch. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( June 11, 2022, 7:16 p.m. UTC
* gnu/packages/golang.scm (go-github-com-jhillyerd-enmime): New
  variable.
---
 gnu/packages/golang.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

M June 11, 2022, 10:53 p.m. UTC | #1
(unmatched-parenthesis via Guix-patches via schreef op za 11-06-2022 om
20:16 [+0100]:
> +It's built on top of Go's included mime/multipart support where possible

Implementation detail.  AFAICT this is not relevant to users of go-
github-com-jhillyerd-enmime.  Instead, maybe you could write about
which MIME things it supports (e.g., does it support reassembly?
mime/alternative? streaming?)?

Greetings,
Maxime.
\( June 12, 2022, 10:37 a.m. UTC | #2
On Sat Jun 11, 2022 at 11:53 PM BST, Maxime Devos wrote:
> Implementation detail.  AFAICT this is not relevant to users of go-
> github-com-jhillyerd-enmime.  Instead, maybe you could write about
> which MIME things it supports (e.g., does it support reassembly?
> mime/alternative? streaming?)?

Noted!
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 34cf0de952..e16af75883 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10255,3 +10255,39 @@  (define-public go-github-com-cention-sany-utf7
      "Package utf7 provides support for the obsolete UTF-7 text encoding
 in Go.")
     (license license:bsd-3)))
+
+(define-public go-github-com-jhillyerd-enmime
+  (package
+    (name "go-github-com-jhillyerd-enmime")
+    (version "0.9.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jhillyerd/enmime")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "124dqm598phbmalyx2gmxk201z9kq4ckvvdq8rc0akjlp24nxqbb"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/jhillyerd/enmime"))
+    (propagated-inputs (list go-golang-org-x-text
+                             go-golang-org-x-net
+                             go-github-com-stretchr-testify
+                             go-github-com-ssor-bom
+                             go-github-com-rivo-uniseq
+                             go-github-com-pkg-errors
+                             go-github-com-olekukonko-tablewriter
+                             go-github-com-mattn-go-runewidth
+                             go-github-com-gogs-chardet
+                             go-github-com-jaytaylor-html2text
+                             go-github-com-go-test-deep
+                             go-github-com-cention-sany-utf7))
+    (home-page "https://github.com/jhillyerd/enmime")
+    (synopsis "Encode and decode MIME")
+    (description
+     "Package enmime implements a MIME encoding and decoding library.
+It's built on top of Go's included mime/multipart support where possible,
+but is geared towards parsing MIME encoded emails.")
+    (license license:expat)))