diff mbox series

[bug#65962,27/33] gnu: Add go-github-com-shurcool-go-importgraphutil.

Message ID f97c30488ab37d93eda52f58b761530324826746.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-shurcool-go-importgraphutil): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:47 a.m. UTC | #1
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65962@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 982c64b660..1c5a72a0ac 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13745,6 +13745,29 @@  (define-public go-github-com-neelance-sourcemap
     (description #f)
     (license license:bsd-2)))
 
+(define-public go-github-com-shurcool-go-importgraphutil
+  (package
+    (name "go-github-com-shurcool-go-importgraphutil")
+    (version "0.0.0-20230706063926-5fe729b41b3a")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/shurcooL/go")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0dym1msgjgywjhsl01frrqx4x4s96pcp1laavs9swz53z5ww95qq"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/shurcooL/go/importgraphutil"
+       #:unpack-path "github.com/shurcooL/go"))
+    (propagated-inputs (list go-golang-org-x-tools))
+    (home-page "https://github.com/shurcooL/go")
+    (synopsis "go")
+    (description "Common Go code.")
+    (license license:expat)))
+
 (define-public go-github-com-vishvananda-netlink
   (package
     (name "go-github-com-vishvananda-netlink")