diff mbox series

[bug#65972,29/33] gnu: Add go-github-com-u-root-uio-rand.

Message ID 7c55604d3cb7846c8774182883cbd3d12e0f09f4.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-u-root-uio-rand): New variable.
---
 gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:48 a.m. UTC | #1
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65972@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 873afbf7dd..198c07910e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13467,6 +13467,35 @@  (define-public go-github-com-u-root-uio-cp
     (description #f)
     (license license:bsd-3)))
 
+(define-public go-github-com-u-root-uio-rand
+  (package
+    (name "go-github-com-u-root-uio-rand")
+    (version "0.0.0-20230305220412-3e8cd9d6bf63")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/u-root/uio")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1gvv66ixkgwikjx8sjdknvrmd08wv2ia02q8n8y3mnkhrgyyx1yf"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/u-root/uio/rand"
+      #:unpack-path "github.com/u-root/uio"
+      #:install-source? #t
+      ;; Source-only package
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; Source-only package
+          (delete 'build))))
+    (home-page "https://github.com/u-root/uio")
+    (synopsis "uio")
+    (description #f)
+    (license license:bsd-3)))
 
 (define-public go-github-com-u-root-gobusybox-src-pkg-bb
   (package