diff mbox series

[bug#65956,16/33] gnu: Add go-github-com-mdlayher-packet.

Message ID a1a361a08b9c8e4931bbc49af67fde06240b4e06.1694675380.git.edk@beaver-labs.com
State New
Headers show
Series Some Go packages | expand

Commit Message

Edouard Klein Sept. 14, 2023, 7:09 a.m. UTC
* gnu/packages/golang.scm (go-github-com-mdlayher-packet): New variable.
---
 gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Edouard Klein Sept. 14, 2023, 7:46 a.m. UTC | #1
help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
>   Katherine Cox-Buday <cox.katherine.e+guix@gmail.com>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 65956@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9723c36dc0..075f341b9b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13503,6 +13503,36 @@  (define-public go-github-com-mdlayher-socket
 support.")
     (license license:expat)))
 
+(define-public go-github-com-mdlayher-packet
+  (package
+    (name "go-github-com-mdlayher-packet")
+    (version "1.1.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mdlayher/packet")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "17jms60j1xygsn5z61r2kz8yywsihf0xjzlhq3v5cpqf08mljwsn"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/mdlayher/packet"
+       #:go ,go-1.20))
+    (propagated-inputs `(("go-golang-org-x-sync" ,go-golang-org-x-sync)
+                         ("go-golang-org-x-sys" ,go-golang-org-x-sys)
+                         ("go-golang-org-x-net" ,go-golang-org-x-net)
+                         ("go-github-com-mdlayher-socket" ,go-github-com-mdlayher-socket)
+                         ("go-github-com-josharian-native" ,go-github-com-josharian-native)
+                         ("go-github-com-google-go-cmp-cmp" ,go-github-com-google-go-cmp-cmp)))
+    (home-page "https://github.com/mdlayher/packet")
+    (synopsis "packet")
+    (description
+     "Package packet provides access to Linux packet sockets (AF_PACKET).")
+    (license license:expat)))
+
+
 (define-public go-github-com-vishvananda-netlink
   (package
     (name "go-github-com-vishvananda-netlink")